The Wall
Forum / THE MAIN WALL / Riello 40 f5 Burner
  • Post a Reply to this Thread

    Riello 40 f5 Burner (6 Posts)

  • king stud king stud @ 9:19 PM
    Contact this user

    Riello Burner

    Hi everyone! I have a Riello 40 f5 burner in my basement, this is the second time in about 5 weeks that the reset button tripped on the unit.I have noticed that both times if you were to tap on the oil solonoid valve and then hit the reset button it would fire up and stay running for the longest time. Do you guys know how to trouble shoot this valve, or should i just replace it totaly. DId filters,nozzle and pump screen but the only thing that seemed to hep was the tapping on solo. THANKS
  • steve steve @ 6:11 AM
    Contact this user

    When was the last time you had your heating system serviced by a competent service tech? You need to start there. If it hasn't been, this might be the answer. Where you having problems before the N/F/S replacement? Is your oil line restricted?
  • Rocky Rocky @ 12:51 PM
    Contact this user

    Resistance test on the solenoid coil

    Riello has a very good troubleshooting chart for their burners. On this chart it tells you what Ohm resistance you should get through the solenoid coil. That would be a good place to start if indeed everything else on the boiler checks out. Like the guys said above: the first thing to determine is if it has been serviced professionally lately. If not, that would be the very first thing to do. Regards, Rocky
  • king stud king stud @ 10:01 PM
    Contact this user

    Riello 40 f5 burner reply

    Thanks guys for your quick responces!the boiler is a Viessmann viterond 200 boiler, the nozzle is a 1.14 gph. 80 degree. the boiler is about 1.5yrs. old. When it was installed i called an oil company to set it up. I did see him check thepump pressure and at the time it was 170psi. I do most of the service my self, changed filters and nozzles and pump strainer. About a month ago i blew out the oil feed line, but not the return line,figured it was filtered. You know since tapping on that damn oil valve solonoid the unit has been running fine again, i think thais the problem. Is it a big deal to change. THANKS AGAIN
  • Erich Erich @ 1:31 AM
    Contact this user

    Make and Model

    It would help us if you told us the make the make and model of the boiler or furnace, the size of the nozzle and if the electrodes were properly gapped and if the burner was set up properly with gauges and if the pump pressure was set to specifications.
  • king stud king stud @ 9:49 PM
    Contact this user

    Hi Erich! thanks for the reply, the boiler is a Viessmann viterond 200, its about 1.5 years old. The nozzle i will have to check on.i did blow out the oil line to the filter with a co2 blow gun, but not the return line , figured the return line was filtered. by tapping on the solonoid the boiler has been running for sevaral days without a hitch,i still think its that oil valve.
  •  
Post a Reply to this Thread