The Wall
Forum / Domestic Hot Water / Rinnai tankless woes
  • Post a Reply to this Thread

    Rinnai tankless woes (68 Posts)

  • kneedeep kneedeep @ 8:39 PM
    Contact this user

    Rinnai tankless woes

    Friend has a residential Rinnai that will run fine, but within 2 minutes of operating, it stops and then starts up again.. It's not a flow problem and we have changed the flow sensor.  City water.  Screens clean.  Backflow cleaning performed twice.  Tech support not friendly.  Gas (NG) pressure fine. Any ideas?  Thanks.
  • Jack Jack @ 10:00 PM
    Contact this user

    Try this...

    I represent Rinnai. For info, who did you speak with at Rinnai? Case# What error codes are you getting? Pull the immersion sensors on the upper rt and at the hot water exit of the unit. It is the 1/8" ss sensore in the well connected with two white wires. Two small phillips head screw. There is an O-ring in the well. Sometimes it stays on the sensor, sometimes in the well, sometimes you don't see it fall to the floor . Is the sensor coated? Sounds like you have climbing temps and it is tripping on limit. Does the unit restart when temps drop? Read the output temp on the unit (push down arrow for at least two seconds and then while holding the down arrow push the on/off button )and monitor the output temps. Are there any indications of condensation coming back to the unit. If there is any debris in the hx fins. You can check by removing the flame rod and sparker. Get a light look up into the bottom of the hx fins. Remove the vent and examine top of the hx for same. If condensation has come back onto the hx and cooked off it will leave a residue which inhibits the the flow of flue gases, which can increase water temps. If a Rinnai exceeds its set-point by 6F it will shut down and restart when temps come down. In this condition it will not generate an error code. It is possible that the gas valve may be malfunctioning, but I'd look elsewhere first.

    Have you flushed the heat exchanger? Have you tested the water for composition? Where are you? If you'd care to chat about it, I'm at 617 834-8751
  • EricAune EricAune @ 9:05 AM
    Contact this user

    First things first

    What is the Rinnai being asked to do? Domestic water heating? Space heating? Is this in a house or on a commercial site? What size is it? How long has it been in use; has it ever ran properly? What did the water sample tests reveal?
    "If you don't like change, your going to like irrelevance even less"
  • Jack Jack @ 5:04 PM
    Contact this user

    How did you make out with this?

    You have a problem, questions are asked, help offered! You throw tech service under the bus and after 5 days don't respond. How are you doing on this? Is your friend okay? What was the fix?
  • Al Letellier Al Letellier @ 1:05 PM
    Contact this user

    Rinnai Issues

    Kneedeep:  listen to Jack....I've known him for years and he's one of the very best. If he can't help you fix it, it's broke !!!!
    Good luck.
  • j a j a @ 9:43 PM
    Contact this user

    tech

    I have installed many of the rinnais and have had only one problem and that was my fault....When I did call for advise I was treated very well and tech guy was knowledgeable   j a
  • j a j a @ 9:43 PM
    Contact this user

    tech

    I have installed many of the rinnais and have had only one problem and that was my fault....When I did call for advise I was treated very well and tech guy was knowledgeable   j a
  • Accutemp Accutemp @ 9:54 PM
    Contact this user

    Rinnia issue

    I have installed a Rinnai RC98. Model back November 2011. And now ther is this problem with the nit after only 6 month of the install. The unit does not ignite - it gives me the error code 12 which means failur to ignite - and on the manual I follow up at the trouble shooting paper across that error 12 everything that ask me to check I have done / gas pressure is good venting good - power is ther everything seems in good conditioning. I have called the Rinnia tech Several time but no help what so ever. .. The unit wich just give me error code right a wake while trying to run it .
    And sometimes only sometime it would work just be punching the on off button ! But that sometimes.

    Any help tip will be helper !! Thanks in advance
  • Jack Jack @ 12:10 PM
    Contact this user

    When you get into

    This type of situation where you feel you are not getting help from tech service you need to do two things. Ask for a service "supervisor". As well, this is when you get your local manuf representative involved. Call them and get them out there. What is your case number?

    Scanning down the list of posts I was delighted and saddened to see a post from Al Letelier. What. Fine man! I miss Al!
  • Jack Jack @ 1:34 AM
    Contact this user

    C'mon man,

    You post with a problem where you are getting no help...and disappear! What is going on? Is it fixed? What is/was the problem?
  • icesailor icesailor @ 7:12 AM
    Contact this user

    No Reply:

    Don't worry about it. It happens all the time to me.
    Just remember, there are people that follow this site that suck vast amounts of information from it. Like myself. Sometimes, the question that is answered (or not) is the question that solves a problem for another.
    Good informative help is hard to get or find. Myself, sometimes, I need to hear myself talk to solve the problem. Sometimes, Tech Support isn't what we would like it to be. Sometimes, tech support gets burned out by stupid questions that a first year hackaroo should know the answer to. Sometimes, I've dealt with Tech Support with a difficult problem and when the tech support person realized that I knew what I was talking about and had far more knowledge than most who called, it became another call. Where we could diagnose the problem properly. I had already covered all the bases.
    Your post from a year or so about the sensor and the O-Rings can be a help. Don't get discouraged.
  • Jack Jack @ 10:09 PM
    Contact this user

    Thanks for that Ice...

    But the lack of response is not discouraging me. It does however piss me off. I think that if you decide to drag up an old post I just think it is respectful and polite to follow-up. I get what you are saying though.

    Again, it did and has given me the opportunity to remember Al, so maybe I shouldn't complain. Thanks for the kind thought Ice!
  • LostAllFaith LostAllFaith @ 2:23 PM
    Contact this user

    Same problem

    I came to this post looking for help with the same issue with my Rinnai. The first unit we had installed malfunctioned after only a few months, giving error code 14. This continued on and off for about a year without an actual cause being found. I pushed and got the installer to pressure Rinnai into sending a replacement unit as this one was obviously faulty. The new unit worked like a charm for about a year and a half, providing hot water for the two units in my house (the main + suite in the basement with tenants). Last November (2012) this new unit started glitching, this time giving the error code 12 (flame failure). The installer came, cleaned the burners and water intake filter (hardly had anything noticeable in there) and couldn't repeat the error. So, problem fixed. Or so he thought. A few weeks later, same error code. He went through every step in the manual, checked everything that could cause this error and came up empty. As the unit failed to show the error while he was on site, Rinnai also could not help the installer figure it out. I was told by my installer to call them when the error was on the unit... which of course only happens on weekends or late at night and they are charging higher rates to come out. It errored again last night and is still glitching this morning, so I'm once more waiting for the tech to come out. Any help or advice into this problem would be greatly appreciated.
  • Aaron_in_Maine Aaron_in_Maine @ 5:51 PM
    Contact this user

    LP

    Is this unit on propane? If this unit is on propane your regulator might be freezing up if its going out when it's real cold outside. Contact your supplier and get them to come out and change the regulator and set the gas pressure that will give you a baseline to start at.
  • Zman Zman @ 10:24 AM
    Contact this user

    Gas line sizing?

    Has anyone looked at you gas line sizing and pressure? All to often these are installed to replace tank hot water heaters with much lower BTU requirements. Everything works OK until other appliances on the line turn on. The gas pressure will then drop and cause an error.
  • LostAllFaith LostAllFaith @ 7:12 PM
    Contact this user

    Rinnai engineer coming

    Aaron, it's not on propane, so it's not that. But thanks for the suggestion.
    Zman: I had my installer come and check everything several times on this issue already. They did come out on Monday and luckily the error code was displayed. Nothing was found out of the ordinary. The installer has now put in a call to the Rinnai engineer for our area and hopefully he will be able to come down within a week. Fingers crossed. I'll let you know what they find.
  • Aaron_in_Maine Aaron_in_Maine @ 7:47 PM
    Contact this user

    Rinnai

    Checkout the thread below titled rinnai r53i-1. The symptoms sound the same. Just have it around when your tech and the rep show up. Might help
  • Jack Jack @ 2:13 PM
    Contact this user

    Something to look at.

    Check your vent termination and the joints on the vent. Is it clear around the vent termination? It is possible that a condensing unit, garbage can, etc may be impacting the vent and re circing exhaust gases. Perhaps one of the joints is partially dis-lodged and in a low fire condition not cross contaminating, but under high fire flue gases are drawn into the fresh air side.

    Your error code 14 on the first unit is in the safety/limits circuit. An open limit will prevent operation. That is a simple series loop and with a digital multimeter the open limit could be identified.
  • LostAllFaith LostAllFaith @ 12:24 AM
    Contact this user

    Tech coming tomorrow... finally

    Hi guys,
    thanks for all the suggestions for the tech to look into. After many calls over the past week, I have a tech coming in tomorrow to try & figure this out. It is NOT the Rinnai tech as promised by my installer, but the installer's senior guy who is going to call into Rinnai as they think they can figure it out that way. They better. I have printed your suggestions and will definitely bring them up. And I will keep you posted as to what they come up with in terms of solution.
    This post was edited by an admin on January 22, 2013 12:26 AM.
  • LostAllFaith LostAllFaith @ 5:40 PM
    Contact this user

    Rinnai fixed?

    The installer's tech came by today and I was able to trigger the error code for him. After running some tests and triggering it several more times, he finally thought of checking the gas pressure. Turns out, in high fire, the unit would drop below the min. requirement (dropped to 3 with the furnace also on, needs 5). So he checked the regulator which was set too low. He admitted he had not checked this before at all. Doh! After he corrected this, we were unable to trigger the error again over the span of an hour and a half.

    I showed him the suggestions from the forum and he checked the vent: no condensation in the unit or in the hose that's the bypass for condensation - no blockages - no buildup in or around it - no dislodged joints. So, should be fine. Gas pipe is 3/4" so also fine. Water is only 1/2" through the house, but 3/4" at the unit. As the unit has worked fine for almost 2 years, he didn't think that could be the issue.

    I was not charged for this visit (and he also fixed my drain while we were running the tests to re-trigger the error!), which was pretty decent I think.
    If this is not the fix, I'll keep the forum posted. If you don't hear anything, it's fixed. Here's hoping I don't have to post again. :-)
  • RobG RobG @ 1:30 PM
    Contact this user

    Gas Pressure

    Although it defiantly sounds like low gas pressure was the issue, you may now have other problems. If your gas piping is sized correctly, with all the appliances in your home firing you should not see a significant drop in gas pressure. By increasing the pressure at the regulator to accommodate the tankless heater, he has now increased the pressure to all of your gas appliances possibly changing the combustion characteristics of them. Your gas pipe sizing needs to be checked! Can you post pictures of the gas piping, regulator(s) and give the distance and BTU ratings of the gas appliances in the home? Everything COULD be OK, but I doubt it.
    Rob 
  • LostAllFaith LostAllFaith @ 2:14 PM
    Contact this user

    Gas pressure check

    Hi Rob,
    Gas pipe is 3/4". Regulator is close to water heater. Furnace is right next to water heater. Stove & fireplace on main floor are the only two other gas appliances in the building. Your input gave me cause for concern so have contacted a different plumber that was recommended to me to come over for a second opinion and double check on this. I'll post my feedback on here as well. Greatly appreciate you taking the time to provide input.
    Ellen
  • HDE HDE @ 9:24 PM
    Contact this user

    Glad to hear its fixed

    So once again
    1. A manufacturer replaced a unit when it wasn't the units fault
    2. The initial installer didn't do his homework, was not a competent or skilled installer and was not able assure the full install was correct
    3. Extensive labor, costs, various people involved, some that shouldn't be because they don't know what their doing
    4. Manufacturer does the best they can with the limited info provided and must trust the techs on site to know what their doing.

    In the end, nearly another black eye for the tankless and appliance industry, and it wasn't their problem - another sad day for those that do have the proper skills & the manufacturer that lost the most in the end.
  • Larry Weingarten Larry Weingarten @ 1:12 AM
    Contact this user

    Gas Pressure

    Hmmm:  As gas pressure is so important for tankless heaters, I wonder how difficult it would be to have a "low gas pressure" error code?  It would make life easier for everyone but the installer who didn't pay attention to gas line sizing.

    Yours,  Larry
  • SteveW SteveW @ 10:38 AM
    Contact this user

    Error Code 25

    Well I just had a Rinnai RC80E installed in Tampa, Florida. I must admit the concept takes a bit getting used coming from a 40 gallon natural gas. However, since the unit has been installed the error code 25 has been coming on. I've read the manual regarding the condensate trap being full and to empy. I've done this and still the same issue. On the bottom of the unit I've a manual screwable plug, another clip type plug, and a 3rd plug which has a black rubber cap that comes off. I contacted Rinnai and their customer service is something left to be desired as they were no help. Any help here in the form would be greatly appreciated, as I am really wondering if these units are what they say they are. Delays from the unit to the service points ( I question effiency at this point as cold water is wasting as you wait for the hot water) Anywhere from a minute to 2 minutes waiting. Then the error code kicks in while your in the shower turning the water cold while all soaped up !
  • icesailor icesailor @ 11:35 AM
    Contact this user

    Error Code 25:

    I remember a conversation with someone who services a lot of stuff. He had a huge problem with one of these (I think it was one of these) and it was a problem with the attatchment of the condensate drain assembly, He went through agony finding it and fixing it. Tech Support wasn't helpful unttil they got on the right track.
    If you can't figure it out, post back and I wil contact him. He finds all kinds of strange problems. He doesn't install them, he just fixes them.
  • LostAllFaith LostAllFaith @ 12:58 PM
    Contact this user

    Rinnai fixed

    Hi there,
    Just thought I'd post a follow up on my story.
    I had a second opinion - had different plumbers come & check the entire installation of my unit.

    They found 2 errors with the installation:
    1. the original installers installed a condensation hose to the top of the unit, where this is a non-condensing unit. According to the 'new' plumbers, this does not create problems, but it should not have been installed.
    2. they installed a regulator on the pipe going to the water heater, which was not necessary either. It's totally superfluous now, as it's cranked open all the way as the unit was starved for gas, which created all the problems in the first place.

    We have not had any issues with the water heater since the gas pressure to the unit was corrected.

    The pressure on the system is fine for all the other appliances as well (new plumbers checked all that out too).

    So, so far so good. Needless to say I will be switching plumbers. :-)
    Thanks so much for your input on this issue. Greatly appreciate it.

    Ellen
  • heatpro02920 heatpro02920 @ 8:23 PM
    Contact this user

    Gas supply is important

    When ever I install a gas tankless, I always over size the gas line, then before we leave I always run all their gas appliances {stoves, dryers, furnaces and boilers, generators everything all at once, and let the unit go to high fire while watching the manometer, if the pressure drops too much, we have to fix it before we leave, I have had to rerun gas lines, hence the always oversizing now...

    Propane brings a few other issues, the only rinnai units I ever seen sooted up were LP and 99% of the time they were being used for space heating...
  • Fred1 Fred1 @ 8:31 PM
    Contact this user

    Code 12 on a 75lsi

    Code 12!! At least once a week we get a code 12 and switch off the tank and on again and it works 2-3 days or maybe a week before again code 12. We changed out the exchanger last winter and since then have spent $1000. on service that has never fixed the problem. The only thing the service people seem to do is clean the igniter and spark rods -temporary relief! Any suggestions?
  • Bigc27 Bigc27 @ 9:30 PM
    Contact this user

    r75lsi code 12

    I keep getting error code 12.  when I turn on the hot water, i can see the flames start but within a couple seconds the code comes on?  any suggestions please.  I have a Rinnai r75lsi. 

    thanks in advance
  • Shakher Shakher @ 9:55 PM
    Contact this user

    Tankless Heater will not turn on

    Hello,

    I have a Rinnai heater that is connected in parallel with another 3 Rinnai units. For almost 2 years we have not had a problem with units (we bought the property through foreclosure and they had been running them 2 years prior to us buying it). This past weekend we had alot of demand for water and the unit would not kick on and we were left with cold showers. There was no error message.

    I did not know a thing about tankless heaters so I began reading about them. I realized that I need to clean the inlet filter and clean it out by running vinegar through it. I bought a pump and ran 4 gallons of vinegar through it. The water was dark black by the end of it. Then I ran 20 gallons through the unit and discharged it out to clear any leftover particles. I tried running the unit and it didn't turn on. I figured it was really dirty, so I did it again and the water came out just as black. Now the unit, when I plug it in turns on runs while there is demand. Then it turns off when there is no demand like it should, but afterwards when there is demand again the unit will not go into "in use"

    I figured there may not be enough water going through the unit so I attached a hose and let cold water run through the unit at 6 GPM it still would not turn on.

    I switched the flow sensor from the unit that was working, with the unit that wasn't working and still the same thing.

    What could be wrong?
  • TPwater TPwater @ 7:50 AM
    Contact this user

    Burner shuts off

    My Rinnai hot water heaters has worked fine for 6 years, but recently it comes on perfectly but shuts down to a code 12 shortly after use.  The gas pressure read a 9 but drops to 1.5 when the unit is heating water.
    It looks as if it is not getting enough gas and the flames just dims and shuts off.
    If I turn off the water flow, it automatically resets and can start again by its self, of course it will only stay on if one faucet is on.  The minute we turn on a shower or another faucet it shuts down again.
    Should the gas supply drop like that when the unit is starting up?
  • Aaron_in_Maine Aaron_in_Maine @ 7:15 PM
    Contact this user

    No

    It should not drop that much. Does it do it all the time or just every once in a while?
  • Matt19 Matt19 @ 4:10 PM
    Contact this user

    Need help with my Rinnai unit

    I just renter a house with a Rinnai R94LS water heater. The house and heater are 3 years old. 50-70% of the time I get a shower, the hot water suddenly stops after just 5-10 minutes and goes completely cold. There is no pattern to when this happens vs when the hot water will last as it should for a indefinite period of time. We have had the gas company check the flow and pressure in the line and we had a plumber just flush the hot water heater system. The hot water heater continues to have issues even after these steps. The heating in the house and the gas stove work without any issue. There is no error code on the system.
  • DebF1 DebF1 @ 3:46 PM
    Contact this user

    Rinnai Brand New system shower goes cold

    Just had new Rinnai tankless gas boiler and domestic water heater installed 3 months ago. Shower sometimes works fine, BUT sometimes the shower comes on fine but within 2 mins the hot goes off and I am left with cold water. The hot does not come back. Domestic heat works fine. No error code...service guy is perplexed....Help..thanks
  • SWEI SWEI @ 4:31 PM
    Contact this user

    Please start a new thread with this title

    and you will get more eyeballs on it.

    thanks~
  • DebF1 DebF1 @ 9:22 PM
    Contact this user

    Rinnai shower water goes cold

    Three month old tank less Rinnai boiler domestic water heating system, still cannot get the unit to work properly. The heat works great, BUT the shower goes cold 2 mins into shower. The unit services two apts. 600sq ft each apt. Kitchen hot water works, shower does not. The shower hot water stops 2 mins in to the shower for each apt. No error code. Hot water does not come back on. I have to wait 12-15mins to get back into the shower and then it does it again. Service guy perplexed...any suggestions? Thanks
  • Zman Zman @ 10:08 AM
    Contact this user

    Suggestion

    I would suggest posting this as a new thread rather than burying in an unrelated 4 year old one.
    You would also get better feedback if you post the model number of you appliance and a picture of the piping around it.
    Carl 
  • heatpro02920 heatpro02920 @ 5:04 PM
    Contact this user

    Service/installer should check....

    first the unit, obviously, if there are no codes, I would stand by the unit and watch it while you run the shower, if the unit stops making hot water but continues to flow water, there is an internal issue, most of which would be shown in the form of an error code....

    Next and most probable, I would look into your shower valve, and or your plumbing, could be a bad washing machine check valve, mixing valve somewhere, ect ect ect.. If it is just the shower, I would tend to look there..

    How about trying to run the shower, and a faucet does the hot water start hot and flow cold at both....
  • Zman Zman @ 9:04 AM
    Contact this user

    Gas line

    What size and type of gas line are supplying  the unit?
  • OutinAZ OutinAZ @ 7:09 PM
    Contact this user

    code 10 again

    can't get this one fixed, not sure of next step.
    keep getting a code10 on R85 after anywhere from 2-5 mins off flow.  initially took of the fan unit and was pretty dirty so cleaned out the spiders and gun and blew it out with air.  after re-assembly same problem.
    spec'ed out the fan according to electrical diagnostics in troubleshooting manual and all checked out good.  got on the roof and checked all the air flow in and out and everything looks clear and unobstructed.
    not sure what the next step is....new PCB?, new fan unit?  hate to just go changing parts out but not sure what to do next as code 10 is supposed to be restricted flow but everything looks ok. 
    bought the house about a year ago with this unit and unit itself is about 6 years old. been running great until a few weeks ago and started doing this off and on, now its more constant.  i've never done a heat exchanger flush but will try that tonight, not sure if that can cause a code 10 but figure its due anyway.  after that I'm not sure of next step.
  • Jack Jack @ 11:43 AM
    Contact this user

    When you cleaned the fan

    Be aware that at the outlet of the fan there is an "diffusion" chamber. It is possible that a dirty fan would also indicate that the diffuser plate above the fan is likewise dirty and could require a brush/vacuum.
  • OutinAZ OutinAZ @ 2:02 PM
    Contact this user

    diffuser clear

    diffuser looks clear.  there is one 45 vent connection just inside the wall so from the roof can't see past that.  next step may be to expose heat exchanger to make sure there's no clogging there.  after that I'll try changing PCB.  what about that temp sensor in fan unit?  those go bad?  fan gets very hot during operation, not sure what operating temp should be
  • OutinAZ OutinAZ @ 6:21 PM
    Contact this user

    solved code 10

    solved this code 10 . finally got to it and removed burner to get a look at heat exchanger.  burner was full of moth's and nest material.  heat exchanger was covered in soot because of improper burning.  blew out the burner and heat exchanger and re-assembled.  unit runs great now, much quieter and running cooler.  build up was so great that unit was actually not burning correctly.  guess if I really looked good would have noticed that flame profile was not correct.  looks much better now.  thanks for the input
  • JZZH JZZH @ 2:09 PM
    Contact this user

    RC98HPi does not heat

    Hi,

    It is not heating. Water flows fine but cold. No error code. Temperature shows 120, priority button on, but "in use" indicator is off even when water is running through.

    Turning on/off power did not help.

    Please advise how to trouble shoot it.

    Thanks.
    Jeffrey
  • Jack Jack @ 6:18 PM
    Contact this user

    Sounds to me like the

    Turbine on the cold water inlet valve is stuck. Do you have debris in the inlet filter? If dirt gets into the turbine it is possible that the turbine wheel isn't turning. Everything tracks off that turbine

    Oh, and the other cause may be cross connected H/C piping. It happens all the time.
  • JZZH JZZH @ 9:52 PM
    Contact this user

    Re: RC98HPi does not heat

    Jack,

    Thanks for the reply. I cleaned cold water inlet filter (just a little bit sand there) but the problem is still there.

    To clarify, this has been working fine for a few years then all of sudden it happened today. The water will run through heater and come out of the hot water pipe but it is just not heated.

    Thanks.
    Jeffrey
  • Jack Jack @ 5:44 PM
    Contact this user

    The turbine "in" the cold water inlet valve

    Is the likely culprit. If the turbine turns and the unit will not fire then the unit would code out 11, tried to fire and failed. Either the turbine is stuck or the flow control unit is bad.
  • JZZH JZZH @ 11:37 PM
    Contact this user

    Re: The turbine "in" the cold water inlet valve

    Hi Jack - I see that there is a cold water inlet valve under the unit. Are you saying that there is a turbine inside that valve that should spin freely? I took off the unit cover and don't see something that looks like a valve inside the unit.
    Curious how if that valve's spinning is relayed to the unit's control function because there is no wire connecting from that valve to the unit - only water goes in. I notice that the manual also says "Ensure turbine spins freely" (I had missed that "no code" row in the "error codes" table before) - how do I check that?
    Pardon my ignorance questions here. You also mentioned flow control unit - where is it located? Thanks a lot for your help.
  • Jack Jack @ 12:27 PM
    Contact this user

    The purpose of

    the inlet filter screen is to keep water borne debris from stopping the turbine wheel from spinning. The turbine is a precise measuring device. It is contained in the Cold water inlet valve immediately above the filter assembly Essentially it has an electronic pick-up on it that reads rpm and the units logic converts that to flow and combustion requirements to arrive at the set point temp.
  • JZZH JZZH @ 1:32 PM
    Contact this user

    Re: The turbine "in" the cold water inlet valve

    Jack - thanks for the explanation. It makes sense but I still have two questions - how do I check if the turbine is turning freely in my situation? How do I know if it's a problem with a stuck turbine or a bad flow control unit?
    Thanks.
    Jeffrey
  • Jack Jack @ 8:22 PM
    Contact this user

    Remove

    The flow control valve. Just inside the filter location is a snap ring. Remove the snap ring and with needle nose you can VERY carefully pull the turbine assembly out. There are two sides forming the body and the impeller itself. Take pictures or at least carefully note the layout of the impeller and two body parts. It's amazing how I have tied myself in knots putting those back together. Re-install and try it. If it isn't that get on the tech line. Number is on side of the cabinet.
  • JZZH JZZH @ 9:49 PM
    Contact this user

    Re: The turbine "in" the cold water inlet valve

    Jack - somehow I did not get a notification after your post so this is a late response.
    I assume the inlet valve is inside the unit (not the shutoff valve beneath the unit) and it is not obvious which one it is. But for now I don't have to worry about that anymore - after some time it started working then it stopped again. I then re-cleaned the inlet filter again and replaced the whole-house water filter. After a day or two it started working again (during the time I always try to use hot water, hoping it will flush out the debris) and has not stopped working yet.
    So indeed it is most likely due to a stuck turbine and luckily I do not have to take it apart to fix it. The lesson is to be diligent in replacing the main filter and clean the unit's inlet filter!
    Thanks a lot for your help!
  • Coldinwyoming Coldinwyoming @ 9:40 PM
    Contact this user

    Code 10

    We have had our Rinnai R53 for 6 years, never had a problem. Yesterday it stopped heating the water on two occasions. Then, later, it worked again. Tonight it stopped working again. I finally went and checked the heater and it shut off while I was there and started flashing the number 10 while beeping. I have no idea about the names of any parts of the machine, unlike most people posting here, and am pretty helpless. Are there any easy fixes or simple things I can check, or should I jut call someone who knows what they are doing? Thanks for any help. Oh, and I cannot find an owners manual, so I have no help there either.
  • OutinAZ OutinAZ @ 6:20 PM
    Contact this user

    code 10

    Most manuals can be found online. It's not to complicated to do some routine maintenance and cleaning. If your unfit table with any of it though it's best to get a professional.
  • Jim Godbout Jim Godbout @ 7:48 PM
    Contact this user

    Flush unit

    Most common problem is people do not service units they require at least a good flush every other year for best performance
    Find good tech in your area and this can be done very reasonably
    Jim Godbout
  • Jack Jack @ 9:22 PM
    Contact this user

    The manual

    Is available at www.rinnai.us. Select water heaters/model/documents and there it is. 10 indicates a high entering air temp. Could just need a cleaning. I'd suggest you call a dealer who has been trained by Rinnai to pull a service call.
  • Zeitgeist Zeitgeist @ 6:20 AM
    Contact this user

    Code 11

    I've got a Rinnai tankless unit that is about 7 years old. It just started flashing code 11 when the hot water is turned on and resetting the temperature.  I've checked on the code which explains that it might be insufficient gas or the igniter failing.  Just curious if anyone knows if this is an expensive fix, is this typical issue after this many years?
  • heatpro02920 heatpro02920 @ 7:44 AM
    Contact this user

    get a tech out there

    have him check out the gas pressure and ignition, I don't normally see many rinnai service calls, it shouldn't be too crazy of a repair... While hes there maybe have him flush the system if you have never done it...
  • Snowmelt Snowmelt @ 11:57 AM
    Contact this user

    Dirt or leak

    Isn't 12 also a sighn of a dirty burner tray, a leak in the heat exchange or flam sencer have to be cleaned?
  • heatpro02920 heatpro02920 @ 2:30 PM
    Contact this user

    12 is the nightmare code

    it can be almost anything, BUT it is most likely cured by a service and no parts needed... 11 will probably need parts...

    I have seen 12 caused by everything from a customer putting a gas grill too close to the exhaust and it diverting the gasses back into the intake to a blocked gas meter....
  • Jack Jack @ 7:07 PM
    Contact this user

    11 & 12

    11 means it tried to fire and failed to do so. 12 means it achieved ignition but couldn't hold operation. 11-no gas, no spark, combustion blower not turning, etc. As noted 12 is where you need your fast ball. That can be air related, dirty blower wheel not supplying enough air, grass clippings in fan, vent pipe separation allowing comb gases into fresh air pipe, did someone move the garbage can in front of the unit so it is recircing flue gas, dirty flame rod, inadequate gas pressure or overdrawn system. Same thing I guess. Bad gas valve. General system being dirty which could lead to lazy flame. Dirty burners. Could be a board, but that is unlikely.

    After 7 years and then a problem, it is time to get a tech in there.
  • heatpro02920 heatpro02920 @ 10:36 PM
    Contact this user

    I hate to see that 12 on there

    Its rare for thee units to go down... I have never seen a bad board in a Rinnai unit, I have heard of them being replaced, but I personally never came across one, and I have seen them soaking wet...

    Propane units can need a cleaning here and there {mostly if they are being used for heat or have close deltas for long periods of time}, but for the most part the units are stable and reliable... Time will tell, they are getting more and more units out there so more issues will arise I am sure, but so far so good...
  • Caseyb Caseyb @ 5:36 PM
    Contact this user

    Error code 10 - R75LSi

    I'm looking for some suggestions on what might be going on with my Rinnai R75LSi. 

    A few years after I bought it, the unit would occasionally shut off (usually mid shower).  Turning the water off and then back on usually took care of the problem.  Eventually I learned that I had enough vent length (caused by elbows mainly) to require me to flip one of the dip switches. So I did that and the problem went away for a while.

    Its back now.  Last weekend I took apart a bit of the venting and cleaned out some spider webs / nests that were in there.  There were a number of them, so I figured that was probably the issue.  I didn't see any more when I put it back together either.

    Well, the code is still happening.  Any suggestions on what might be causing it?  I really don't think it is a blocked vent.
  • Fred1 Fred1 @ 4:37 PM
    Contact this user

    code 12 on a 75lsi

    posted last Aug. about a continual code 12. Think we finally got it! when the exchanger was replaced, the gasket was not. The tech didn't have one with him so he heat sealed it on the outside and it has worked perfectly ever since. Hopefully annual maintenance will keep it running.
  • Rockhoppert Rockhoppert @ 1:07 PM
    Contact this user

    Rinnai RC98HPi code 12

    I have a code 12 that was showing on my unit, so no hot water. Also no flame visible through the site glass. Ithoguht this meant an electrical fault in the unit. Been trying for 2 days periodically and now all of a sudden it works again. What is likely causing the issue?
  • r306 r306 @ 3:01 PM
    Contact this user

    rinnai on demand heater working on an off

    Hi,I have a on demand r5 water heater .Anyways sometimes it works good ,but lots of times when using hot water it will get hot then turn cold again continuously until you shut water off and on a few times .Then you can get it to work again.It puts out no error code .Could some one please help with this?
    Thanks.
  • Blewis Blewis @ 9:14 PM
    Contact this user

    Rinnai Condensation Tube Clogging

    My condensation tube off my Rinnai has become clogged with a white sludge. I have noticed what looks like a metal residue in the past and this has never been an issue.
    Does anyone know what this white matter could be and is it possible to have metal filings/particles in the consensation tube?

    Thanks for aly advice/help.
  •  
Post a Reply to this Thread