The Wall
Forum / Controls / WM GV6 Boiler Honywell intergrated boiler control
  • Post a Reply to this Thread

    WM GV6 Boiler Honywell intergrated boiler control (3 Posts)

  • fiat fiat @ 2:05 PM
    Contact this user

    WM GV6 Boiler Honywell intergrated boiler control

    I have 2 GV6 Weil McLain boilers. The one that is not working has a
    Honeywell S9301A1001 integrated boiler control
    The green power light is on
    the purge light is flashing which means the air flow is not proven
    My other boiler has the updated model 1013-200 integrated boiler control.
    Is my problem the boiler control module or is there possibly another issue.
    what does it mean that the air flow is not proven?
    This post was edited by an admin on January 30, 2011 3:22 PM.
  • Tim McElwain Tim McElwain @ 3:25 PM
    Contact this user

    The purge light flashing

    indicates a problem with air flow.indicates that the combustion air blower system is at fault. C heck the blower and the pressure switch.

    Is the combustion air blower running? If so then check the pressure switch, check hoses for blockage, or hose could have a kink somewhere. To prove place your multimeter as the gas valve load (disconnect wires of gas valve) and jump out the pressure switch. The igniter light should come on (RED) and then the valve flame light. If it does and it will not come on with pressure switch in the circuit then get a digital manometer and check the suction pressure to the pressure switch. The pressure must be 1.4" W.C.or greater, if not check hoses, loose blower wheel on CAB, blower RPM too low, air inlet from vent has blockage watch for ice, disconnect the flue and see if it runs okay with the flue disconnected if it does then something is blocking either the intake air or the flue exhaust, also check the condensate line and make sure it is clear and not frozen.
  • fiat fiat @ 5:04 PM
    Contact this user

    Problem Solved

    The bearings in the blower motor were dry and it was not spinning well.  Oiled the top and bottom of the motor.  Also found the hose to the blower housing was disconnected on the top and partially off on the bottom.  Reconnected and problem solved.
  •  
Post a Reply to this Thread