The Wall
Forum / Controls / Tekmar 508 and Taco Zone Controls
  • Post a Reply to this Thread

    Tekmar 508 and Taco Zone Controls (3 Posts)

  • fatty fatty @ 1:51 PM
    Contact this user

    Tekmar 508 and Taco Zone Controls

    Hi there,
    I am running into issues with this set up. The story: I built this system many years ago, maybe 5... and it sat for some years in a house that was never finished. Thieves eventually broke in and cut out all of my copper work... leaving the electronic components and some pumps just dangling in the wind.

    A friend of mine bought the house - and completed it - and as a favor I offered to rebuild the system. Unfortunately I do not remember what my design was... I just did my best to reimagine what I had originally planned and tried to fill in the blanks.

    The issue I am hitting right away in with the Tekmar thermostats. When I connect them to the Zone control (with 120v circulators, not zone valves) They light up, but show no display. No numbers, no info, no error messages or codes. They also immediately cycle on the zones... each circulator slams on at once.

    One relay clicks rapidly and the circulator fails to start. I am guessing that one is frozen from sitting out of use for so long (the system was drained but wet enough to rust I suppose). In this picture I have them disconnected to stop them from running constantly.

    The thermostats I really have no guesses for... but this was my first time using this set up. I am not even gotten to the point of wiring the boiler, aquastat, etc. but just wanted to see that the thermostat wiring I had originally placed had not been damaged during the remodel.

    These Tekmar units have a slab sensor as well... which is 2 wire. They control 2 isolated radiant slabs within the home.

    Thank you so much... for your time
    Tom
  • Empire Empire @ 3:26 PM
    Contact this user

    Hi fatty.

    Considering that the house was ran sacked, think like everything is damaged.  What I am thinking is a short somewhere in the lo vac control circuitry.  Have you tried to jump out your t-stats manually with jumper?  At least we can verify if the Taco controller is good or bad.  Since you mentioned chattering relay, I does sound like a short.  From there check wiring at wall one at a time.  I am thinking since you can start from the Taco controller first, then jump the heat circuit out at the t-stat locations.  This will take some time, but you need to find the faulty circuit before you can go any further.  I'll bet the intruders possibly ripped through a wire or two.


    Mike T.
  • Dave H Dave H @ 9:55 AM
    Contact this user

    Tekmar 508 wiring

    This thermostat is a 4-wire stat. 2 are for power and two for endswitch.

    Wiring to the ZVC board, the endswitch wire go to "TT" on the ZVC.
    Your 24 volt power to the stat can also come from the ZVC, but use the terminal on the top left on the controller.

    Dave H
  •  
Post a Reply to this Thread