The Wall
Forum / THE MAIN WALL / Whining RBI 600 Dominator
  • Post a Reply to this Thread

    Whining RBI 600 Dominator (11 Posts)

  • Dave Dave @ 11:05 PM
    Contact this user

    Whining RBI 600 Dominator

    I have a copper boiler that has been in place for fifteen months . It provides both space heat as well as domestic hot water by way of a turbo max. The system is piped p/s through a low loss header. The gas pressures are correct and the flow rate is 20 degrees delta T across the heat exchanger at high fire. The system has not made up any water to speak of. The building is approx. twenty feet high to the top of the radiation. The system pressure is 18-20 PSI. Two weeks ago the boiler began to whine as it approached the set point of 175 degrees. The system did not appear to be dirty when the equipment was replaced. Why would this problem start now? I would appreciate any help
  • nicholas bonham-carter nicholas bonham-carter @ 11:42 PM
    Contact this user

    Whining system

    Is the boiler piped in rigid iron pipe for the gas supply?
    There has been mention here of a whine coming through the piping as a resulted using flexible gas line which had a certain resonance.--NBC
  • Dave Dave @ 8:07 AM
    Contact this user

    Ridgid pipe

    Yes , the boiler is piped in ridgid pie and is properly sized
  • Dave Dave @ 8:07 AM
    Contact this user

    Ridgid pipe

    Yes , the boiler is piped in ridgid pie and is properly sized
  • Dave Dave @ 8:07 AM
    Contact this user

    Ridgid pipe

    Yes , the boiler is piped in ridgid pie and is properly sized
  • Dave Dave @ 8:07 AM
    Contact this user

    Ridgid pipe

    Yes , the boiler is piped in ridgid pie and is properly sized
  • Dave Dave @ 8:07 AM
    Contact this user

    Whining RBI 600 Dominator

    Yes , the boiler is piped in ridgid pie and is properly sized
    This post was edited by an admin on December 3, 2012 8:11 AM.
  • Mark Eatherton Mark Eatherton @ 11:57 PM
    Contact this user

    The fix...

    Common problem with copper and steel fin tube boilers, usually with glycol, but have seen it happen without.

    ME

    http://www.heatinghelp.com/forum-thread/143488/Water-treatment-for-copper-fin-snowmelt-system

    ME
    It's not so much a case of "You got what you paid for", as it is a matter of "You DIDN'T get what you DIDN'T pay for, and you're NOT going to get what you thought you were in the way of comfort". Borrowed from Heatboy.
  • Dave Dave @ 11:34 PM
    Contact this user

    RbI whining boiler

    Thanks for the info Mark. I think you nailed the problem diagnosing buildup inside the tubes. I feel that after 15 months some type of film or scale has bonded and is causing localized flashing. What are your thoughts on valveing off the boiler and circulating a cleaner through the HX and then flushing. Would it be better to go after the entire system?
  • Dave Dave @ 11:35 PM
    Contact this user

    RbI whining boiler

    Thanks for the info Mark. I think you nailed the problem diagnosing buildup inside the tubes. I feel that after 15 months some type of film or scale has bonded and is causing localized flashing. What are your thoughts on valveing off the boiler and circulating a cleaner through the HX and then flushing. Would it be better to go after the entire system?
  • Mark Eatherton Mark Eatherton @ 7:36 AM
    Contact this user

    Treat the system as a whole...

    Not that expensive and may circumvent other issues associated with the bio slime that may be fouling up the works.

    ME
    It's not so much a case of "You got what you paid for", as it is a matter of "You DIDN'T get what you DIDN'T pay for, and you're NOT going to get what you thought you were in the way of comfort". Borrowed from Heatboy.
  •  
Post a Reply to this Thread