The Wall
Forum / Strictly Steam / automatic water feed issue
  • Post a Reply to this Thread

    automatic water feed issue (5 Posts)

  • REM REM @ 8:42 AM
    Contact this user

    automatic water feed issue

    the bypass button on the automatic water feed does not work and the automatic water feed is coming on everytimethe boiler comes on as the water goes below the designated mark.  I emptied the boiler so I could clean the spy glass and it took over an hour to refill to the cut off level line which is only an inch from the bottom of the spy glass.  something is making the water go in very slow and the red bypass button not work.  is there something I can clean out to make this work the way it should? this just started last weekend  The Heat is working fine. All radiators getting hot.

    also.  do you know a local supply where I can get radiator valves with a plastic control on the bottom as a regulator?  Home Depot and Lowes do not carry these.
    thanks
    Rem
  • STEAM DOCTOR STEAM DOCTOR @ 9:49 PM
    Contact this user

    auto feed

    Auto feeds are not a very good thing to have on your steam boiler.
    1. You will never know if you have leaks.
    2. If you have leaks and the auto feed keeps refilling the boiler then you boiler lifespan will be shortened due to oxidation from the oxygen in the fresh water.
    3. The auto feed typically maintains a safe operating water level and not an efficient water level.
    4.Auto feeds have a bad habit(not common but it happens) of opening and not closing with will fill the boiler, then the radiators and then your house with water.
    If you don't have any leaks in the then you should not have to fill you system more the once a month MAX!
  • MTC MTC @ 10:19 PM
    Contact this user

    Autofeeders

    are good and bad, bn covered some of the reasons they're bad. There are good reasons to have them too (such as your house won't freeze and burst pipes while you're on a 3 week vacation for Xmas and the boiler water level dropped too low on day 2).

    Regardless of that discussion, your issue: autofeeders are supposed to be slow, so they don't overfill the boiler. Why the manual feed isn't working, not sure. The way I usually like to see them set up is the water line coming to the autofeeder splits off, and goes through a ball valve, and connects to the other side of the feeder. You've piped a bypass with a valve.

    Draining your boiler to clean the sight glass seems excessive. You see those little round knobs on the top and bottom of the sight glass? Just turn the bottom one clockwise all the way, and you can take out the sight glass. Remember to open it back up again once you put the glass back in.
  • STEAM DOCTOR STEAM DOCTOR @ 10:43 PM
    Contact this user

    Agreed MTC

    I tell my customers that if they really want auto feeders for that reason they should leave them off and turn them on when they go on vacation.
  • Hap_Hazzard Hap_Hazzard @ 9:47 PM
    Contact this user

    You need to call a pro.

    If the manual feed button isn't working, you can't trust it to work when the LWCO signals a low water condition. You should get it serviced. Also, you should have a bypass valve for filling the boiler. Fill water should not register on the meter--the meter should always read zero so you can tell when the feeder has activated and fix whatever caused it. Ordinarily a water feeder should never activate. It is a safety device. Use the manual feed button only for testing.

    When the feeder is removed for service they can check to see why it's filling so slowly. They can also check your fluctuating water level. This needs to be fixed because it can shorten the life of your boiler. Something might be delaying the return of condensate to the boiler, and there are several things that can cause this.

    I don't know of a source for the Vent-Rite #1. They're a reasonably good vent, but they're getting hard to find. Amazon carries the Maid-o-Mist 0220-5L, which comes with 5 different orifices. This offers the benefits of a variable vent and a fixed vent.
    1983(?) Peerless G-561-W-S

    3" drop header, CG400-1090, VXT-24
  •  
Post a Reply to this Thread