The Wall
Forum / Indoor-Air Quality / Honeywell Humidifier HE300 Problem
  • Post a Reply to this Thread

    Honeywell Humidifier HE300 Problem (2 Posts)

  • RussC RussC @ 1:56 PM
    Contact this user

    Honeywell Humidifier HE300 Problem

    I have a Trol A Temp TZ3 and am installing a Honeywell HE300 Humidifier. It's all hooked up but I think I have a wiring issue since it is not functioning at all. The 120VAC is plugged in and I get initial lights so unit has power. But water will not flow and call for power does nothing. I have the supplied humidistat connected and it ohms out correctly. I have W from HE300 to HVAC Control W on TZ3. The Common wire I'm not sure about since there is no C terminal on TZ3. I connected C from HE300 to a thermostat M1 on TZ3. M1 is a thermostat common. There is also a 24V common I think on TZ3 labeled as TR1 but have not tried that. Don't want to cook the HE300. When furnace calls for heat there is no reaction in HE300 from either water flow or built-in fan.
  • BillW BillW @ 8:58 PM
    Contact this user

    HE300

    The HE 300 Truease humidifier is a new model of fan powered humidifier. You can find all the wiring information if you go to www.customer.honeywell.com annd scroll down to the bottom of the page, click on residential, and follow the prompts. The instruction sheet is 72 pages long, so it may take a while to load.

    I don't know if it is compatible with a Trol-a-Temp stat; those are older technology, and from the literature, it seems like it comes with its own controller, or works with one of the stats with humidifier capability. The typical sequence of operation should go like this: On a call for heat, if the humidistat senses a need for humidification, the solenoid should open starting the water flow. These newer models may have a delay so that the fan does not start until the pad is wet, but I am not sure of that, but the fan should start and run until the humidistat is satisfied or the call for heat ends.
  •  
Post a Reply to this Thread