The Wall
Forum / Gas Heating / williamson steam boiler not working? Need help
  • Post a Reply to this Thread

    williamson steam boiler not working? Need help (7 Posts)

  • genolegakis genolegakis @ 9:56 AM
    Contact this user

    williamson steam boiler not working? Need help

    I have a one year old Williamson gas fired steam boiler that was in the house I just purchased. It was working well for a week before the system stopped. When you jump the two thermostat wires the system starts and works fine. It had the old t87 round thermostat which I changed and still did not work. I changed the thermo wire all the way to boiler and still not working unless I jump the wires. I then changed the 24V transformer-relay and the same problem. I was getting low voltage readings before I changed transformer and now after the change readings are normal but system still does not work if I don't jump the wires. I don't know what the problem is????? 
  • earl burnermann earl burnermann @ 12:24 PM
    Contact this user

    What else could it be?

    In your post you said that when you jumped out the thermostat wires it worked. Did you jump them out at the thermostat? If you did then the only problem it could be is the thermostat. Hopefully, all the changes you made since then have not added to the problem.
    If the women don't find you handsome, they should at least find you handy!
  • genolegakis genolegakis @ 12:32 PM
    Contact this user

    jumping the wires

    Yes, I did. I jump the wires right at the thermostat, where they hang out of the wall where the thermostat connects to them. By the way,  I have tried three different t87 thermostats. Should I try a different thermostat??  digital maybe??
    This post was edited by an admin on December 17, 2013 12:34 PM.
  • JStar JStar @ 8:33 PM
    Contact this user

    T-stat

    What is the model number of the thermostat? What is the model of the boiler?
    - Joe Starosielec
    732-494-4357
    j.star@thatcherhvac.com
    http://thatcherhvac
    http://facebook.com/thatcherhvac


    Guaranteed performance. Guaranteed energy savings.

    Serving all of NJ, NYC, Southern NY State, and eastern PA.
    Consultation anywhere.
    (Formerly "ecuacool")
  • genolegakis genolegakis @ 12:33 AM
    Contact this user

    honeywell t87

    After all that I did, change thermostat wire from boiler to thermostat, change transformer-relay...test all lines with voltmeter...the 3 different t87 honeywells did not work when connected to the wires. Finally I bought a different brand manual thermostat and connected the two wires and l I HAVE HEAT.........damn t87 honeywell..will never buy another again
  • JStar JStar @ 6:13 AM
    Contact this user

    T-stat

    It was probably a power stealing thermostat, which does not work with boilers equipped with automatic vent dampers. Don't blame the thermostat...
    - Joe Starosielec
    732-494-4357
    j.star@thatcherhvac.com
    http://thatcherhvac
    http://facebook.com/thatcherhvac


    Guaranteed performance. Guaranteed energy savings.

    Serving all of NJ, NYC, Southern NY State, and eastern PA.
    Consultation anywhere.
    (Formerly "ecuacool")
  • Tim McElwain Tim McElwain @ 12:55 PM
    Contact this user

    Just by chance were

    the T87 thermostats T87F-1849 or 1859, if so they have to wired a special way as they were designed to replace SPST and SPDT (Series 20 ) thermostats.
  •  
Post a Reply to this Thread