The Wall
Forum / Domestic Hot Water / HTP Phoenix LD Condensate Neutralizer Leak
  • Post a Reply to this Thread

    HTP Phoenix LD Condensate Neutralizer Leak (2 Posts)

  • Ahoy Ahoy @ 8:00 PM
    Contact this user

    HTP Phoenix LD Condensate Neutralizer Leak

    I cannot figure out why this condensate drain is leaking. 

    Phoenix LD water heater with neutralizer cartridge mounted to trap on underside of exhaust pipe.  The neutralizer allows a default right drain but this one was moved to the left side, with a tee immediately next to the water heater to prevent airlock.  The neutralizer body (on the exhaust line) has a 1/2" stub with a bell end that inserts to nearly full depth in the hole on the cartridge. 

    After firing up the heater, it ran for three weeks flawlessly.  Now it is leaking condensate from the connection between the neutralizer body and the neutralizer cartridge. 

    To eliminate field work from the equation, I disconnected the condensate tubing completely.  Some water dripped from the outlet fitting, but just as much dripped from between the neutralizer body and cartridge.  Since it raises the outlet about 1/4", I then unscrewed the barbed fitting from the 1/2" threaded outlet on the cartridge.  No difference, still dripping. 

    Checked the cartridge for free-flow and level.  Flow is fine when fed with syringe at a rate far exceeding the normal condensate flow.  Cartridge when mounted is within 1/16" of level; bubble is nearly at center. 

    Checked the body for obstructions, none seen with mirror. 

    The only issue I can see is that when the cartridge is pushed all the way in, the body and cartridge have a 1/16" gap between them.  Since the stub inserts almost a half-inch into the cartridge, I guessed that was not enough to make a difference, but could I be wrong? 
  • Ahoy Ahoy @ 4:23 PM
    Contact this user

    Resolved

    The manufacturer indicated it was a known problem.  The fix for now is to put a rubber garden hose washer between the exhaust body and the neutralizer cartridge. I did that and it's been working fine.  
  •  
Post a Reply to this Thread