Security Seal Facebook Twitter GooglePlus Pinterest Newsletter Sign-up
The Wall
rpezz50

rpezz50

Joined on November 5, 2013

Last Post on November 7, 2013

Contact User

Recent Posts

Pic

@ November 7, 2013 1:35 PM in Cast iron radiator not getting hot

Should this be leaking?

Install

@ November 6, 2013 10:03 PM in Cast iron radiator not getting hot

The odd part is that before the boiler was replaced all heating elements work and with the new boiler is pipe the same way the old one was.

Pump

@ November 5, 2013 10:15 PM in Cast iron radiator not getting hot

You know I had thoughts that the pump was under size. Can you point me in the right direction for a bigger pump? Also I think that pump came with the boiler.

Ok

@ November 5, 2013 9:45 PM in Cast iron radiator not getting hot

They are the same width and the valve are all fully open. It did work before the boiler was replace. Anything else I can do?

?

@ November 5, 2013 9:32 PM in Cast iron radiator not getting hot

Ok not sure what I am looking for is it a valve? Is in in any of the pics I sent?

Cast iron radiator not getting hot

@ November 5, 2013 9:22 PM in Cast iron radiator not getting hot

Hi guys I had my boiler replaced about 6 month ago I now have a Budures g115 with the Logamatic. I have been told that I have cast iron baseboards on a venturi system. It's a two-story house with only 1 zone the kitchen has the cast iron radiator that's is not getting hot. I have Bleed the system and I have water coming out of the bleeder the only time I can get the radiator hot is when I'm bleeding the system and letting the water drain out. One side if the piping is hot but on the return side is cold. The radiator worked before the boiler was replaced. Am I missing something? When I bleed the system no air comes out only water and if I keep bleeding the radiator I do get hot water but it won't stay hot and gets cold.

I will upload pics